Tuesday, January 31, 2012

Getting dependency error for 'twitter-bootstrap-rails' when upgrading to rails 3.2

While upgrading to Rails 3.2, done changes in assets like:

gem 'rails', '3.2.0'

group :assets do
  gem 'sass-rails', "  ~> 3.2.3"
  gem 'coffee-rails', "~> 3.2.1"
  gem 'uglifier', '>= 1.0.3'
gem 'twitter-bootstrap-rails'

And run 'bundle update', it gives following error:

Fetching source index for http://rubygems.org/
Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    twitter-bootstrap-rails (>= 0) ruby depends on
      actionpack (~> 3.1.1) ruby

    rails (= 3.2.0) ruby depends on
      actionpack (3.2.0)

To fix the issue change the code in Gemfile from
gem 'twitter-bootstrap-rails'
gem 'twitter-bootstrap-rails', :git => 'http://github.com/seyhunak/twitter-bootstrap-rails.git'

And run 'bundle update'

No comments:

Post a Comment